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Some data Is missing after migrating the platform

Problem

After migrating your BILLmanager 6 platform to a new server, some sections of the interface display incomplete data. For example, you may notice missing records in Clients Clients, BillingPayments, or Products/Services. However, all the records are still present in the database.

This issue occurs because a trial license is active on the new server. The BILLmanager 6 trial version is limited to a maximum of 10 clients. If your database contains more clients than the license allows, the web interface hides the excess records along with their associated payments and services.

Diagnosis

This problem is confirmed when both of the following conditions are true:

  • the database contains more records than the web interface displays;
  • a trial license is active on the destination server. 

To verify the cause:

  1. Compare the number of records in the database with those in the web interface:
    1. Connect to the server with the platform via SSH. For more information about connecting via SSH, see Workstation setup.

      There are potential risks involved in altering a database. We do not recommend making manual edits to the database, as it can disrupt the correct operation of the platform.

      Create a backup of the platform before performing any actions with the database.

    2. Connect to the database:
      mysql billmgr
    3. Run the following query to get the exact number of clients:
      select count(*) from account;
      Example output
      select count(*) from account;
      +----------+
      | count(*) |
      +----------+
      | 9904 |
      +----------+
      1 row in set (0.00 sec)
      Comment
    4. Note the result. For example, the output above shows the database contains 9904 clients.
    5. Compare this number with the records shown in the web interface. Go to Clients Clients. Indicator of the problem: the web interface displays significantly fewer records than are present in the database.
  2. Confirm a trial license is active on the destination server:
    • via the web interface:
      1. Go to HelpAbout program.
      2. Check the Control panel field. If the license is trial, it will indicate Trial.
    • via the Client Area:
      1. Go to Products/ServicesLicenses.
      2. Find the license attached to the destination server.
      3. Check the license type. The trial version is indicated by a corresponding mark in the tariff or the Period column.

Indicator of the problem: a trial license is confirmed to be active on the destination server.

Solution

To resolve the issue:

  1. Activate a commercial license on the destination server. For details, refer to the guide Types of licences.
  2. Verify that all records are displayed in Clients Clients.
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